MikroTik Auto backup by email

Дали ще е достатъчна толкова RAM за станция? Ех, този 132 колонен текстов режим! И още...
Отговори
morphieus
Мнения: 1331
Регистриран: 08-11-2004 16:57
Име: Слав Димитров
Местоположение: Ловеч
Контакти:

MikroTik Auto backup by email

Мнение от morphieus » 26-02-2018 20:41

Микротик - достъп и изключително функционален рутер, който е способен да се гъне по желание :)

Под мой надзор са повече от 30 рутера. Във всеки от тях правя настройки или наблюдавам как се държат периодично. Целият този процес е тромав и трудоемък, за това отделих малко време и постигнах слената функционалност:

Код: Избери всички

- По зададен интервал всеки рутер прави автоматичен архив на цялата си конфигурация и я изпраща по и-мейл.
Към момента нямам полеви резултати при изгорял рутер какво се случва, но на теория, изпратеният прикачен файл съдържа цялата нужна информация за "съживяването" на един изгубен такъв.

Код: Избери всички

/system script add name="e-mail-backup" source={/system backup save name=email;
/tool e-mail send to="username@yourcompany.com" subject=([/system identity get name]." backup") file=email.backup; :log info "Backup e-mail sent.";  }
/system scheduler add comment="" disabled=no interval=7d name="e-mail-backup" \ on-event=e-mail-backup start-date=jan/01/1970 start-time=00:00:00

Код: Избери всички

/tool e-mail set address=IP_SMTP_HOST port=SMTP_port from=<username@yourcompany.com> user=username@yourcompany.com password=email_password
Стойности:

Код: Избери всички

IP_SMTP_HOST - 78.128.1.74 (за mail.unrealsoft.net)
SMTP_port - 25 (за mail.unrealsoft.net)
Изображение

boris
Мнения: 517
Регистриран: 24-07-2009 17:21

Re: MikroTik Auto backup by email

Мнение от boris » 28-02-2018 17:46

Екстра. Едно предложение ако може, според мен по-добре ще е архива да се прави в *.rsc формат, така лесно ще може да редактираш файла и да го нагодиш към друго устройство за друг клиент, ако проблема не е в плейн текста които се получава.
Два месеца работа с компютъра спестява два часа четене на документация

morphieus
Мнения: 1331
Регистриран: 08-11-2004 16:57
Име: Слав Димитров
Местоположение: Ловеч
Контакти:

Re: MikroTik Auto backup by email

Мнение от morphieus » 28-02-2018 21:31

Дай повече за този формат. Схемата е базирана на вградени възможности на Микротик ОС и за това е именно толкова ценна, копи/пейст и работи!

Ако твоето предложение е съвместно с направената организация към момента ще обновя темата
Изображение

boris
Мнения: 517
Регистриран: 24-07-2009 17:21

Re: MikroTik Auto backup by email

Мнение от boris » 01-03-2018 22:26

Идеята ми бе, ако ти се занимава да пробваш да се замени реда:
/system backup save name=email
с
/export file=email. най добре ако стане и с двата файла едновременно.

Съответно наливането обратно става с Import file=email. Пробвай в конзолата и виж резултата. Предимството за мен е че става плеин текст, а не бинарен файл, което предполага възможността да се ресторне върху различна версия на рутера.
Два месеца работа с компютъра спестява два часа четене на документация

Отговори